#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/([^\/]+)\/?$"
Local $sString = "http://falloutboy.com/111" & @CRLF & _
"http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki" & @CRLF & _
"http://www.adobe.com/ru/" & @CRLF & _
"http://www.mamba.ru/en/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")