const regex = /\/([^\/]+)\/?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/([^\\\/]+)\\\/?$', '')
const str = `http://falloutboy.com/111
http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki
http://www.adobe.com/ru/
http://www.mamba.ru/en/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}