package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/([^\/]+)\/?$`)
var str = `http://falloutboy.com/111
http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki
http://www.adobe.com/ru/
http://www.mamba.ru/en/
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}