$re = '/\/([^\/]+)\/?$/';
$str = 'http://falloutboy.com/111
http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki
http://www.adobe.com/ru/
http://www.mamba.ru/en/
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);