import Foundation
let pattern = #"^(https:\/\/youtu\.be\/|http:\/\/www\.youtube\.com\/watch\?v=).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.youtube.com/watch?v=u8nQa1cJyX8
https://youtu.be/x3ov9USxVxY
sdfgsdg dfsgdfsgdf
https://youtu.be/u8nQa1cJyX8
sdfsfsdfs-foo-dsfsdf
foohfghdfghsdsfgh
barfghfghdfghfgh
dfghdfghdfghdfg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)