#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https:\/\/youtu\.be\/|http:\/\/www\.youtube\.com\/watch\?v=).*$"
Local $sString = "http://www.youtube.com/watch?v=u8nQa1cJyX8" & @CRLF & _
"https://youtu.be/x3ov9USxVxY" & @CRLF & _
"sdfgsdg dfsgdfsgdf" & @CRLF & _
"https://youtu.be/u8nQa1cJyX8" & @CRLF & _
"sdfsfsdfs-foo-dsfsdf" & @CRLF & _
"foohfghdfghsdsfgh" & @CRLF & _
"barfghfghdfghfgh" & @CRLF & _
"dfghdfghdfghdfg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")