import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https:\\/\\/youtu\\.be\\/|http:\\/\\/www\\.youtube\\.com\\/watch\\?v=).*$";
final String string = "http://www.youtube.com/watch?v=u8nQa1cJyX8\n"
+ "https://youtu.be/x3ov9USxVxY\n"
+ "sdfgsdg dfsgdfsgdf\n"
+ "https://youtu.be/u8nQa1cJyX8\n"
+ "sdfsfsdfs-foo-dsfsdf\n"
+ "foohfghdfghsdsfgh\n"
+ "barfghfghdfghfgh\n"
+ "dfghdfghdfghdfg\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}