$re = '/^(https:\/\/youtu\.be\/|http:\/\/www\.youtube\.com\/watch\?v=).*$/m';
$str = 'http://www.youtube.com/watch?v=u8nQa1cJyX8
https://youtu.be/x3ov9USxVxY
sdfgsdg dfsgdfsgdf
https://youtu.be/u8nQa1cJyX8
sdfsfsdfs-foo-dsfsdf
foohfghdfghsdsfgh
barfghfghdfghfgh
dfghdfghdfghdfg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);