const regex = /^(https:\/\/youtu\.be\/|http:\/\/www\.youtube\.com\/watch\?v=).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https:\\\/\\\/youtu\\.be\\\/|http:\\\/\\\/www\\.youtube\\.com\\\/watch\\?v=).*$', 'gm')
const str = `http://www.youtube.com/watch?v=u8nQa1cJyX8
https://youtu.be/x3ov9USxVxY
sdfgsdg dfsgdfsgdf
https://youtu.be/u8nQa1cJyX8
sdfsfsdfs-foo-dsfsdf
foohfghdfghsdsfgh
barfghfghdfghfgh
dfghdfghdfghdfg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}