re = /^(https:\/\/youtu\.be\/|http:\/\/www\.youtube\.com\/watch\?v=).*$/m
str = 'http://www.youtube.com/watch?v=u8nQa1cJyX8
https://youtu.be/x3ov9USxVxY
sdfgsdg dfsgdfsgdf
https://youtu.be/u8nQa1cJyX8
sdfsfsdfs-foo-dsfsdf
foohfghdfghsdsfgh
barfghfghdfghfgh
dfghdfghdfghdfg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end