re = /^(\d*)\d{2}$/
str = '26090837916945379538252700000004491630000002580'
subst = '26090837916945379538252700000004491630000002580'
result = str.sub(re, subst)
# Print the result of the substitution
puts result