# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d*)\d{2}$/26090837916945379538252700000004491630000002580/;t' <<< "26090837916945379538252700000004491630000002580"