import Foundation
let pattern = #"^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
BTS_33_198_D
PL_14_015
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\\\2\3\\_%\5%"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)