# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?/\1\\\2\3\\_%\5%/gm;t' <<< "BTS_33_198_D
PL_14_015
"