using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?";
string substitution = @"\1\\\2\3\\_%\5%";
string input = @"BTS_33_198_D
PL_14_015
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}