#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?"
Local $sString = "BTS_33_198_D" & @CRLF & _
"PL_14_015" & @CRLF & _
""
Local $sSubst = "\1\\\2\3\\_%\5%"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)