re = /^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?/m
str = 'BTS_33_198_D
PL_14_015
'
subst = '\\1\\\\\\2\\3\\\\_%\\5%'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result