import Foundation
let pattern = #"([1-9][0-9]*(?:\.[0-9]{1,})?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[来访量]*100.112-[响应时长]/60.0187+2.1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}