const regex = /([1-9][0-9]*(?:\.[0-9]{1,})?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1-9][0-9]*(?:\\.[0-9]{1,})?)', '')
const str = `[来访量]*100.112-[响应时长]/60.0187+2.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}