$re = '/([1-9][0-9]*(?:\.[0-9]{1,})?)/';
$str = '[来访量]*100.112-[响应时长]/60.0187+2.1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);