package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([1-9][0-9]*(?:\.[0-9]{1,})?)`)
var str = `[来访量]*100.112-[响应时长]/60.0187+2.1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}