using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([1-9][0-9]*(?:\.[0-9]{1,})?)";
string input = @"[来访量]*100.112-[响应时长]/60.0187+2.1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}