re = /\"(\\([[:alpha:]]|[^[:alpha:]])|[^\n\"])*[^\\]\"/m
str = '"test\\b\\""
"test\\"\\b "
"test\\
newl"
"123"
" "
"quote\'\'\'\'"
"test\\"\\b\\000"
""
"test \\"
"test
wrong"
"test \\
"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end