$re = '/\"(\\\\([[:alpha:]]|[^[:alpha:]])|[^\n\"])*[^\\\\]\"/m';
$str = '"test\\b\\""
"test\\"\\b "
"test\\
newl"
"123"
" "
"quote\'\'\'\'"
"test\\"\\b\\000"
""
"test \\"
"test
wrong"
"test \\
"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);