const regex = /\"(\\([[:alpha:]]|[^[:alpha:]])|[^\n\"])*[^\\]\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"(\\\\([[:alpha:]]|[^[:alpha:]])|[^\\n\\"])*[^\\\\]\\"', 'gm')
const str = `"test\\b\\""
"test\\"\\b "
"test\\
newl"
"123"
" "
"quote''''"
"test\\"\\b\\000"
""
"test \\"
"test
wrong"
"test \\
"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}