import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"(\\\\([[:alpha:]]|[^[:alpha:]])|[^\\n\\\"])*[^\\\\]\\\"";
final String string = "\"test\\b\\\"\"\n"
+ "\"test\\\"\\b \"\n\n"
+ "\"test\\\n"
+ "newl\"\n\n"
+ "\"123\"\n\n"
+ "\" \"\n\n"
+ "\"quote''''\"\n\n\n"
+ "\"test\\\"\\b\\000\"\n\n"
+ "\"\"\n\n"
+ "\"test \\\"\n\n"
+ "\"test\n"
+ "wrong\"\n\n"
+ "\"test \\\n"
+ "\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}