#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\"(\\([[:alpha:]]|[^[:alpha:]])|[^\n\"])*[^\\]\""
Local $sString = ""test\b\""" & @CRLF & _
""test\"\b "" & @CRLF & _
"" & @CRLF & _
""test\" & @CRLF & _
"newl"" & @CRLF & _
"" & @CRLF & _
""123"" & @CRLF & _
"" & @CRLF & _
"" "" & @CRLF & _
"" & @CRLF & _
""quote''''"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""test\"\b\000"" & @CRLF & _
"" & @CRLF & _
"""" & @CRLF & _
"" & @CRLF & _
""test \"" & @CRLF & _
"" & @CRLF & _
""test" & @CRLF & _
"wrong"" & @CRLF & _
"" & @CRLF & _
""test \" & @CRLF & _
"""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")