// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((.+)\)").unwrap();
let string = "System: Info requested on possible debts seen in bankstatements (Thorn Group, Afterpay, Openpay, Zip Pay, Afterpay, Zip Pay, Deferit)
System: Info requested on possible debts seen in bankstatements (Panthera Finance, Pioneer Credit, InDebted, Cash Converters, Moneyspot, Zipmoney, Openpay, Complete Credit, Zipmoney, CBA Loans, Zip Pay, Beforepay, MyPayNow, Wagetap, Wagepay, Press Pay, CBA StepPay)
System: Info requested on possible debts seen in bankstatements (Swoosh Finance, Afterpay, Zip Pay, Beforepay)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}