const regex = /\((.+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.+)\\)', 'gm')
const str = `System: Info requested on possible debts seen in bankstatements (Thorn Group, Afterpay, Openpay, Zip Pay, Afterpay, Zip Pay, Deferit)
System: Info requested on possible debts seen in bankstatements (Panthera Finance, Pioneer Credit, InDebted, Cash Converters, Moneyspot, Zipmoney, Openpay, Complete Credit, Zipmoney, CBA Loans, Zip Pay, Beforepay, MyPayNow, Wagetap, Wagepay, Press Pay, CBA StepPay)
System: Info requested on possible debts seen in bankstatements (Swoosh Finance, Afterpay, Zip Pay, Beforepay)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}