#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\((.+)\)"
Local $sString = "System: Info requested on possible debts seen in bankstatements (Thorn Group, Afterpay, Openpay, Zip Pay, Afterpay, Zip Pay, Deferit)" & @CRLF & _
"" & @CRLF & _
"System: Info requested on possible debts seen in bankstatements (Panthera Finance, Pioneer Credit, InDebted, Cash Converters, Moneyspot, Zipmoney, Openpay, Complete Credit, Zipmoney, CBA Loans, Zip Pay, Beforepay, MyPayNow, Wagetap, Wagepay, Press Pay, CBA StepPay)" & @CRLF & _
"" & @CRLF & _
"System: Info requested on possible debts seen in bankstatements (Swoosh Finance, Afterpay, Zip Pay, Beforepay)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")