$re = '/\((.+)\)/m';
$str = 'System: Info requested on possible debts seen in bankstatements (Thorn Group, Afterpay, Openpay, Zip Pay, Afterpay, Zip Pay, Deferit)
System: Info requested on possible debts seen in bankstatements (Panthera Finance, Pioneer Credit, InDebted, Cash Converters, Moneyspot, Zipmoney, Openpay, Complete Credit, Zipmoney, CBA Loans, Zip Pay, Beforepay, MyPayNow, Wagetap, Wagepay, Press Pay, CBA StepPay)
System: Info requested on possible debts seen in bankstatements (Swoosh Finance, Afterpay, Zip Pay, Beforepay)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);