package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((.+)\)`)
var str = `System: Info requested on possible debts seen in bankstatements (Thorn Group, Afterpay, Openpay, Zip Pay, Afterpay, Zip Pay, Deferit)
System: Info requested on possible debts seen in bankstatements (Panthera Finance, Pioneer Credit, InDebted, Cash Converters, Moneyspot, Zipmoney, Openpay, Complete Credit, Zipmoney, CBA Loans, Zip Pay, Beforepay, MyPayNow, Wagetap, Wagepay, Press Pay, CBA StepPay)
System: Info requested on possible debts seen in bankstatements (Swoosh Finance, Afterpay, Zip Pay, Beforepay)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}