import Foundation
let pattern = #"(select top [0-9]+ percent|select top [0-9]+|select )"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"seLect top 21 campo, campo from tabela select top 100 percent teste 2 top "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)