$re = '/(select top [0-9]+ percent|select top [0-9]+|select )/i';
$str = 'seLect top 21 campo, campo from tabela select top 100 percent teste 2 top ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);