re = /(select top [0-9]+ percent|select top [0-9]+|select )/i
str = 'seLect top 21 campo, campo from tabela select top 100 percent teste 2 top '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end