using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(select top [0-9]+ percent|select top [0-9]+|select )";
string input = @"seLect top 21 campo, campo from tabela select top 100 percent teste 2 top ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}