// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(select top [0-9]+ percent|select top [0-9]+|select )").unwrap();
let string = "seLect top 21 campo, campo from tabela select top 100 percent teste 2 top ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}