// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<div.*?>(.*?)<\/div>").unwrap();
let string = "<div id=\"_mcePaste\">
<ul>
<li> Computer is stolen </li>
<li> Someone else has gained access to your certificate </li>
<li> Employee leaves or transfers to another department </li>
<li> Certificate is corrupted </li>
</ul>
Links:
<p>http://customs.gov.au/webdata/resources/files/digital_certificate_and_client_registrations.pdf</p>
<p></p>
</div>";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}