import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div.*?>(.*?)<\\/div>";
final String string = "<div id=\"_mcePaste\">\n"
+ "<ul>\n"
+ "<li> Computer is stolen </li>\n"
+ "<li> Someone else has gained access to your certificate </li>\n"
+ "<li> Employee leaves or transfers to another department </li>\n"
+ "<li> Certificate is corrupted </li>\n"
+ "</ul>\n"
+ "Links:\n"
+ "<p>http://customs.gov.au/webdata/resources/files/digital_certificate_and_client_registrations.pdf</p>\n"
+ "<p></p>\n"
+ "</div>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}