$re = '/(<ComponentSearchFormField(?:[^<]*?))(\s+)type="inputSearch"((?:[^>]*?)\/>)/';
$str = '
<div className="ui celled grid">
<div className="row">
<ComponentSearchFormField
columnWidth="8"
type="inputSearch"
model={depositPrototype}
field="company"
sourceCollection={Companies}
baseCriteria={{isActive: true}}
/>
<ComponentSearchFormField
disableValidation
type="inputSearch"
model={depositPrototype}
disableValidation
title="Currency Code"
sourceCollection={CurrencyCodes}
baseCriteria={{isActive: true}}
/>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);