use strict;
my $str = '
<div className="ui celled grid">
<div className="row">
<ComponentSearchFormField
columnWidth="8"
type="inputSearch"
model={depositPrototype}
field="company"
sourceCollection={Companies}
baseCriteria={{isActive: true}}
/>
<ComponentSearchFormField
disableValidation
type="inputSearch"
model={depositPrototype}
disableValidation
title="Currency Code"
sourceCollection={CurrencyCodes}
baseCriteria={{isActive: true}}
/>';
my $regex = qr/(<ComponentSearchFormField(?:[^<]*?))(\s+)type="inputSearch"((?:[^>]*?)\/>)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}