const regex = /(<ComponentSearchFormField(?:[^<]*?))(\s+)type="inputSearch"((?:[^>]*?)\/>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<ComponentSearchFormField(?:[^<]*?))(\\s+)type="inputSearch"((?:[^>]*?)\\\/>)', '')
const str = `
<div className="ui celled grid">
<div className="row">
<ComponentSearchFormField
columnWidth="8"
type="inputSearch"
model={depositPrototype}
field="company"
sourceCollection={Companies}
baseCriteria={{isActive: true}}
/>
<ComponentSearchFormField
disableValidation
type="inputSearch"
model={depositPrototype}
disableValidation
title="Currency Code"
sourceCollection={CurrencyCodes}
baseCriteria={{isActive: true}}
/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}