using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<ComponentSearchFormField(?:[^<]*?))(\s+)type=""inputSearch""((?:[^>]*?)\/>)";
string input = @"
<div className=""ui celled grid"">
<div className=""row"">
<ComponentSearchFormField
columnWidth=""8""
type=""inputSearch""
model={depositPrototype}
field=""company""
sourceCollection={Companies}
baseCriteria={{isActive: true}}
/>
<ComponentSearchFormField
disableValidation
type=""inputSearch""
model={depositPrototype}
disableValidation
title=""Currency Code""
sourceCollection={CurrencyCodes}
baseCriteria={{isActive: true}}
/>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}