package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<ComponentSearchFormField(?:[^<]*?))(\s+)type="inputSearch"((?:[^>]*?)\/>)`)
var str = `
<div className="ui celled grid">
<div className="row">
<ComponentSearchFormField
columnWidth="8"
type="inputSearch"
model={depositPrototype}
field="company"
sourceCollection={Companies}
baseCriteria={{isActive: true}}
/>
<ComponentSearchFormField
disableValidation
type="inputSearch"
model={depositPrototype}
disableValidation
title="Currency Code"
sourceCollection={CurrencyCodes}
baseCriteria={{isActive: true}}
/>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}