import Foundation
let pattern = #"((?<!as\s|:\s|import\s|<|\|\s))DevExpress"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
// Examples of lines to ignore
import DevExpress from '../bundles/dx.all';
ExchangeSyncServiceContainer: DevExpress.ui.dxTabPanel;
editorOptions: <DevExpress.ui.dxDataGridOptions>{
| DevExpress.ui.dxFormSimpleItem[]
// DevExpress
// Examples of lines to find
export type Options = DevExpress.viz.dxRangeSelectorOptions;
DevExpress.ui.notify('', '', '');
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)