const regex = /((?<!as\s|:\s|import\s|<|\|\s))DevExpress/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<!as\\s|:\\s|import\\s|<|\\|\\s))DevExpress', 'sg')
const str = `// Examples of lines to ignore
import DevExpress from '../bundles/dx.all';
ExchangeSyncServiceContainer: DevExpress.ui.dxTabPanel;
editorOptions: <DevExpress.ui.dxDataGridOptions>{
| DevExpress.ui.dxFormSimpleItem[]
// DevExpress
// Examples of lines to find
export type Options = DevExpress.viz.dxRangeSelectorOptions;
DevExpress.ui.notify('', '', '');
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}