#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)((?<!as\s|:\s|import\s|<|\|\s))DevExpress"
Local $sString = "// Examples of lines to ignore" & @CRLF & _
"import DevExpress from '../bundles/dx.all';" & @CRLF & _
"ExchangeSyncServiceContainer: DevExpress.ui.dxTabPanel;" & @CRLF & _
"editorOptions: <DevExpress.ui.dxDataGridOptions>{" & @CRLF & _
"| DevExpress.ui.dxFormSimpleItem[]" & @CRLF & _
"// DevExpress" & @CRLF & _
"" & @CRLF & _
"// Examples of lines to find" & @CRLF & _
"export type Options = DevExpress.viz.dxRangeSelectorOptions;" & @CRLF & _
"DevExpress.ui.notify('', '', '');" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")