import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!as\\s|:\\s|import\\s|<|\\|\\s))DevExpress";
final String string = "// Examples of lines to ignore\n"
+ "import DevExpress from '../bundles/dx.all';\n"
+ "ExchangeSyncServiceContainer: DevExpress.ui.dxTabPanel;\n"
+ "editorOptions: <DevExpress.ui.dxDataGridOptions>{\n"
+ "| DevExpress.ui.dxFormSimpleItem[]\n"
+ "// DevExpress\n\n"
+ "// Examples of lines to find\n"
+ "export type Options = DevExpress.viz.dxRangeSelectorOptions;\n"
+ "DevExpress.ui.notify('', '', '');\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}