$re = '/((?<!as\s|:\s|import\s|<|\|\s))DevExpress/s';
$str = '// Examples of lines to ignore
import DevExpress from \'../bundles/dx.all\';
ExchangeSyncServiceContainer: DevExpress.ui.dxTabPanel;
editorOptions: <DevExpress.ui.dxDataGridOptions>{
| DevExpress.ui.dxFormSimpleItem[]
// DevExpress
// Examples of lines to find
export type Options = DevExpress.viz.dxRangeSelectorOptions;
DevExpress.ui.notify(\'\', \'\', \'\');
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);