$re = '/^.*reddit\.com\/?(?!(?:message|comments)\/).*?$/m';
$str = 'https://www.reddit.com/r/MechanicalKeyboards/comments/7xtvwj/black_like_my_soul/
https://www.reddit.com/message/inbox/
https://www.reddit.com/r/allcomments/asdf
https://www.reddit.com/r/MechanicalKeyboards
https://www.reddit.com/r/MechanicalKeyboards/
https://www.reddit.com/r/hearthstone/?count=25&after=t3_7y194s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);